What’s Vulnerable › Vulnerabilities
CVE-2019-20628
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-24 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in libgpac.a in GPAC before 0.8.0, as demonstrated by MP4Box. It contains a Use-After-Free vulnerability in gf_m2ts_process_pmt in media_tools/mpegts.c that can cause a denial of service via a crafted MP4 file.
Affected products
- GPAC: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: GPAC 0.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/1ab4860609f2e7a35634930571e7d0531297e090
- https://github.com/gpac/gpac/commit/98b727637e32d1d4824101d8947e2dbd573d4fc8
- https://github.com/gpac/gpac/issues/1269
- https://github.com/gpac/gpac/commit/1ab4860609f2e7a35634930571e7d0531297e090
- https://github.com/gpac/gpac/commit/98b727637e32d1d4824101d8947e2dbd573d4fc8
- https://github.com/gpac/gpac/issues/1269
Get alerted when CVE-2019-20628 or the next vulnerability affects your stack