What’s Vulnerable › Vulnerabilities
CVE-2019-20637
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-08 · updated 2026-06-17
- Weakness: CWE-212
Description
An issue was discovered in Varnish Cache before 6.0.5 LTS, 6.1.x and 6.2.x before 6.2.2, and 6.3.x before 6.3.1. It does not clear a pointer between the handling of one client request and the next request within the same connection. This sometimes causes information to be disclosed from the connection workspace, such as data structures associated with previous requests within this connection or VCL-related temporary headers.
Affected products
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
- Varnish-Cache Varnish Cache: from 6.1.0 before 6.2.2; from 6.3.0 before 6.3.1 — fixed in 6.2.2, 6.3.1
- varnish-software Varnish Cache: from 6.0.0 before 6.0.5 — fixed in 6.0.5
How to fix
Upgrade to a fixed version: Varnish-Cache Varnish Cache 6.2.2, 6.3.1; varnish-software Varnish Cache 6.0.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00031.html
- http://varnish-cache.org/security/VSV00004.html#vsv00004
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00031.html
- http://varnish-cache.org/security/VSV00004.html#vsv00004
Get alerted when CVE-2019-20637 or the next vulnerability affects your stack