What’s Vulnerable › Vulnerabilities
CVE-2019-20651
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-15 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects WAC505 before 8.2.1.16 and WAC510 before 8.2.1.16.
Affected products
- NETGEAR Wac505 Firmware: before 8.2.1.16 — fixed in 8.2.1.16
- NETGEAR Wac510 Firmware: before 8.2.1.16 — fixed in 8.2.1.16
How to fix
Upgrade to a fixed version: NETGEAR Wac505 Firmware 8.2.1.16; NETGEAR Wac510 Firmware 8.2.1.16. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061491/Security-Advisory-for-Post-Authentication-Command-Injection-on-WAC505-and-WAC510-PSV-2019-0176
- https://kb.netgear.com/000061491/Security-Advisory-for-Post-Authentication-Command-Injection-on-WAC505-and-WAC510-PSV-2019-0176
Get alerted when CVE-2019-20651 or the next vulnerability affects your stack