What’s Vulnerable › Vulnerabilities
CVE-2019-20655
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-15 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects XR500 before 2.3.2.56 and XR700 before 1.0.1.20.
Affected products
- NETGEAR Xr500 Firmware: before 2.3.2.56 — fixed in 2.3.2.56
- NETGEAR Xr700 Firmware: before 1.0.1.20 — fixed in 1.0.1.20
How to fix
Upgrade to a fixed version: NETGEAR Xr500 Firmware 2.3.2.56; NETGEAR Xr700 Firmware 1.0.1.20. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061484/Security-Advisory-for-Post-Authentication-Command-Injection-on-XR500-and-XR700-PSV-2019-0026
- https://kb.netgear.com/000061484/Security-Advisory-for-Post-Authentication-Command-Injection-on-XR500-and-XR700-PSV-2019-0026
Get alerted when CVE-2019-20655 or the next vulnerability affects your stack