What’s Vulnerable › Vulnerabilities

CVE-2019-20657

Description

Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects D6200 before 1.1.00.36, D7000 before 1.0.1.74, PR2000 before 1.0.0.28, R6020 before 1.0.0.42, R6080 before 1.0.0.42, R6050 before 1.0.1.24, JR6150 before 1.0.1.24, R6120 before 1.0.0.48, R6220 before 1.1.0.86, R6230 before 1.1.0.86, R6260 before 1.1.0.64, R6700v2 before 1.2.0.62, R6800 before 1.2.0.62, R6900v2 before 1.2.0.62, and WNR2020 before 1.1.0.62.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6200 Firmware 1.1.00.36; NETGEAR D7000 Firmware 1.0.1.74; NETGEAR JR6150 1.0.1.24; NETGEAR Pr2000 Firmware 1.0.0.28; NETGEAR R6020 Firmware 1.0.0.42; NETGEAR R6050 Firmware 1.0.1.24; NETGEAR R6080 Firmware 1.0.0.42; NETGEAR R6120 Firmware 1.0.0.48; NETGEAR R6220 Firmware 1.1.0.86; NETGEAR R6230 Firmware 1.1.0.86; NETGEAR R6260 1.1.0.64; NETGEAR R6700 1.2.0.62. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20657 or the next vulnerability affects your stack