What’s Vulnerable › Vulnerabilities
CVE-2019-20658
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-15 · updated 2026-06-17
Description
Certain NETGEAR devices are affected by disclosure of sensitive information. This affects FS728TLP before 1.0.1.26, GS105Ev2 before 1.6.0.4, GS105PE before 1.6.0.4, GS108Ev3 before 2.06.08, GS108PEv3 before 2.06.08, GS110EMX before 1.0.1.4, GS116Ev2 before 2.6.0.35, GS408EPP before 1.0.0.15, GS808E before 1.7.0.7, GS810EMX before 1.7.1.1, GS908E before 1.7.0.3, GSS108E before 1.6.0.4, GSS108EPP before 1.0.0.15, GSS116E before 1.6.0.9, JGS516PE before 2.6.0.35, JGS524Ev2 before 2.6.0.35, JGS524PE before 2.6.0.35, XS512EM before 1.0.1.1, XS708Ev2 before 1.6.0.23, XS716E before 1.6.0.23, and XS724EM before 1.0.1.1.
Affected products
- NETGEAR Fs728Tlp Firmware: before 1.0.1.26 — fixed in 1.0.1.26
- NETGEAR Gs105E Firmware: before 1.6.0.4 — fixed in 1.6.0.4
- NETGEAR Gs105Pe Firmware: before 1.6.0.4 — fixed in 1.6.0.4
- NETGEAR Gs108E Firmware: before 2.06.08 — fixed in 2.06.08
- NETGEAR Gs108Pe Firmware: before 2.06.08 — fixed in 2.06.08
- NETGEAR Gs110Emx Firmware: before 1.0.1.4 — fixed in 1.0.1.4
- NETGEAR Gs116E Firmware: before 2.6.0.35 — fixed in 2.6.0.35
- NETGEAR Gs408Epp Firmware: before 1.0.0.15 — fixed in 1.0.0.15
- NETGEAR Gs808E Firmware: before 1.7.0.7 — fixed in 1.7.0.7
- NETGEAR Gs810Emx Firmware: before 1.7.1.1 — fixed in 1.7.1.1
- NETGEAR Gs908E Firmware: before 1.7.0.3 — fixed in 1.7.0.3
- NETGEAR Gss108E Firmware: before 1.6.0.4 — fixed in 1.6.0.4
- NETGEAR Gss108Epp Firmware: before 1.0.0.15 — fixed in 1.0.0.15
- NETGEAR Gss116E Firmware: before 1.6.0.9 — fixed in 1.6.0.9
- NETGEAR Jgs516Pe Firmware: before 2.6.0.35 — fixed in 2.6.0.35
- NETGEAR Jgs524E Firmware: before 2.6.0.35 — fixed in 2.6.0.35
- NETGEAR Jgs524Pe Firmware: before 2.6.0.35 — fixed in 2.6.0.35
- NETGEAR Xs512Em Firmware: before 1.0.1.1 — fixed in 1.0.1.1
- NETGEAR Xs708E Firmware: before 1.6.0.23 — fixed in 1.6.0.23
- NETGEAR Xs716E Firmware: before 1.6.0.23 — fixed in 1.6.0.23
- NETGEAR Xs724Em Firmware: before 1.0.1.1 — fixed in 1.0.1.1
How to fix
Upgrade to a fixed version: NETGEAR Fs728Tlp Firmware 1.0.1.26; NETGEAR Gs105E Firmware 1.6.0.4; NETGEAR Gs105Pe Firmware 1.6.0.4; NETGEAR Gs108E Firmware 2.06.08; NETGEAR Gs108Pe Firmware 2.06.08; NETGEAR Gs110Emx Firmware 1.0.1.4; NETGEAR Gs116E Firmware 2.6.0.35; NETGEAR Gs408Epp Firmware 1.0.0.15; NETGEAR Gs808E Firmware 1.7.0.7; NETGEAR Gs810Emx Firmware 1.7.1.1; NETGEAR Gs908E Firmware 1.7.0.3; NETGEAR Gss108E Firmware 1.6.0.4. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061481/Security-Advisory-for-Sensitive-Information-Disclosure-on-Some-Switches-PSV-2018-0612
- https://kb.netgear.com/000061481/Security-Advisory-for-Sensitive-Information-Disclosure-on-Some-Switches-PSV-2018-0612
Get alerted when CVE-2019-20658 or the next vulnerability affects your stack