What’s Vulnerable › Vulnerabilities
CVE-2019-20659
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-15 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects R6400v2 before 1.0.4.84, R6700 before 1.0.2.8, R6700v3 before 1.0.4.84, R6900 before 1.0.2.8, and R7900 before 1.0.3.10.
Affected products
- NETGEAR R6400 Firmware: before 1.0.4.84 — fixed in 1.0.4.84
- NETGEAR R6700: before 1.0.2.8; before 1.0.4.84 — fixed in 1.0.2.8, 1.0.4.84
- NETGEAR R6900 Firmware: before 1.0.2.8 — fixed in 1.0.2.8
- NETGEAR R7900 Firmware: before 1.0.3.10 — fixed in 1.0.3.10
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.4.84; NETGEAR R6700 1.0.2.8, 1.0.4.84; NETGEAR R6900 Firmware 1.0.2.8; NETGEAR R7900 Firmware 1.0.3.10. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061480/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2018-0567
- https://kb.netgear.com/000061480/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2018-0567
Get alerted when CVE-2019-20659 or the next vulnerability affects your stack