What’s Vulnerable › Vulnerabilities

CVE-2019-20680

Description

Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D7000v2 before 1.0.0.53, R6220 before 1.1.0.80, R6260 before 1.1.0.64, R6700 before 1.0.2.6, R6700v2 before 1.2.0.36, R6800 before 1.2.0.36, R6900 before 1.0.2.4, R6900P before 1.3.1.64, R6900v2 before 1.2.0.36, R7000 before 1.0.9.60, R7000P before 1.3.1.64, R7800 before 1.0.2.60, R7900 before 1.0.3.8, R7900P before 1.4.1.30, R8000 before 1.0.4.46, R8000P before 1.4.1.30, R8300 before 1.0.2.128, R8500 before 1.0.2.128, R8900 before 1.0.4.12, R9000 before 1.0.4.12, and XR500 before 2.3.2.32.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D7000 Firmware 1.0.0.53; NETGEAR R6220 Firmware 1.1.0.80; NETGEAR R6260 1.1.0.64; NETGEAR R6700 1.0.2.6, 1.2.0.36; NETGEAR R6800 Firmware 1.2.0.36; NETGEAR R6900 Firmware 1.0.2.4, 1.2.0.36; NETGEAR R6900P Firmware 1.3.1.64; NETGEAR R7000 1.0.9.60; NETGEAR R7000P 1.3.1.64; NETGEAR R7800 Firmware 1.0.2.60; NETGEAR R7900 Firmware 1.0.3.8; NETGEAR R7900P Firmware 1.4.1.30. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20680 or the next vulnerability affects your stack