What’s Vulnerable › Vulnerabilities

CVE-2019-20682

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.76, D6000 before 1.0.0.76, D6200 before 1.1.00.32, D7000 before 1.0.1.68, JR6150 before 1.0.1.18, PR2000 before 1.0.0.28, R6020 before 1.0.0.38, R6050 before 1.0.1.18, R6080 before 1.0.0.38, R6120 before 1.0.0.46, R6220 before 1.1.0.80, R6260 before 1.1.0.40, R6700v2 before 1.2.0.36, R6800 before 1.2.0.36, R6900v2 before 1.2.0.36, WNR2020 before 1.1.0.62, and XR500 before 2.3.2.32.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.76; NETGEAR D6000 Firmware 1.0.0.76; NETGEAR D6200 Firmware 1.1.00.32; NETGEAR D7000 Firmware 1.0.1.68; NETGEAR JR6150 1.0.1.18; NETGEAR Pr2000 Firmware 1.0.0.28; NETGEAR R6020 Firmware 1.0.0.38; NETGEAR R6050 Firmware 1.0.1.18; NETGEAR R6080 Firmware 1.0.0.38; NETGEAR R6120 Firmware 1.0.0.46; NETGEAR R6220 Firmware 1.1.0.80; NETGEAR R6260 1.1.0.40. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20682 or the next vulnerability affects your stack