What’s Vulnerable › Vulnerabilities
CVE-2019-20691
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-352
Description
Certain NETGEAR devices are affected by CSRF. This affects D3600 before 1.0.0.72, D6000 before 1.0.0.72, EX3700 before 1.0.0.70, EX3800 before 1.0.0.70, EX6000 before 1.0.0.30, EX6100 before 1.0.2.24, EX6120 before 1.0.0.40, EX6130 before 1.0.0.22, EX6150v1 before 1.0.0.42, EX6200 before 1.0.3.88, EX7000 before 1.0.0.66, and WN2500RPv2 before 1.0.1.54.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR D6000 Firmware: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR EX3700: before 1.0.0.70 — fixed in 1.0.0.70
- NETGEAR Ex3800 Firmware: before 1.0.0.70 — fixed in 1.0.0.70
- NETGEAR Ex6000 Firmware: before 1.0.0.30 — fixed in 1.0.0.30
- Netgear EX6100: before 1.0.2.24 — fixed in 1.0.2.24
- NETGEAR EX6120: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR Ex6130 Firmware: before 1.0.0.22 — fixed in 1.0.0.22
- Netgear EX6150: before 1.0.0.42 — fixed in 1.0.0.42
- Netgear EX6200: before 1.0.3.88 — fixed in 1.0.3.88
- NETGEAR Ex7000 Firmware: before 1.0.0.66 — fixed in 1.0.0.66
- NETGEAR Wn2500Rp Firmware: before 1.0.1.54 — fixed in 1.0.1.54
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.72; NETGEAR D6000 Firmware 1.0.0.72; NETGEAR EX3700 1.0.0.70; NETGEAR Ex3800 Firmware 1.0.0.70; NETGEAR Ex6000 Firmware 1.0.0.30; Netgear EX6100 1.0.2.24; NETGEAR EX6120 1.0.0.40; NETGEAR Ex6130 Firmware 1.0.0.22; Netgear EX6150 1.0.0.42; Netgear EX6200 1.0.3.88; NETGEAR Ex7000 Firmware 1.0.0.66; NETGEAR Wn2500Rp Firmware 1.0.1.54. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061448/Security-Advisory-for-Cross-Site-Request-Forgery-on-Some-Gateways-and-Extenders-PSV-2017-2747
- https://kb.netgear.com/000061448/Security-Advisory-for-Cross-Site-Request-Forgery-on-Some-Gateways-and-Extenders-PSV-2017-2747
Get alerted when CVE-2019-20691 or the next vulnerability affects your stack