What’s Vulnerable › Vulnerabilities
CVE-2019-20694
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
Description
Certain NETGEAR devices are affected by disclosure of sensitive information. This affects GS728TP before 6.0.0.48, GS728TPPv2 before 6.0.0.48, GS728TPv2 before 6.0.0.48, GS752TPP before 6.0.0.48, and GS752TPv2 before 6.0.0.48.
Affected products
- NETGEAR Gs728Tp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
- NETGEAR Gs728Tpp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
- NETGEAR Gs752Tp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
- NETGEAR Gs752Tpp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
How to fix
Upgrade to a fixed version: NETGEAR Gs728Tp Firmware 6.0.0.48; NETGEAR Gs728Tpp Firmware 6.0.0.48; NETGEAR Gs752Tp Firmware 6.0.0.48; NETGEAR Gs752Tpp Firmware 6.0.0.48. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061235/Security-Advisory-for-Sensitive-Information-Disclosure-on-Some-Switches-PSV-2019-0059
- https://kb.netgear.com/000061235/Security-Advisory-for-Sensitive-Information-Disclosure-on-Some-Switches-PSV-2019-0059
Get alerted when CVE-2019-20694 or the next vulnerability affects your stack