What’s Vulnerable › Vulnerabilities
CVE-2019-20697
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects GS728TPPv2 before 6.0.0.48, GS728TPv2 before 6.0.0.48, GS750E before 1.0.1.4, GS752TPP before 6.0.0.48, and GS752TPv2 before 6.0.0.48.
Affected products
- NETGEAR Gs728Tp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
- NETGEAR Gs728Tpp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
- NETGEAR Gs750E Firmware: before 1.0.1.4 — fixed in 1.0.1.4
- NETGEAR Gs752Tp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
- NETGEAR Gs752Tpp Firmware: before 6.0.0.48 — fixed in 6.0.0.48
How to fix
Upgrade to a fixed version: NETGEAR Gs728Tp Firmware 6.0.0.48; NETGEAR Gs728Tpp Firmware 6.0.0.48; NETGEAR Gs750E Firmware 1.0.1.4; NETGEAR Gs752Tp Firmware 6.0.0.48; NETGEAR Gs752Tpp Firmware 6.0.0.48. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061232/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Switches-PSV-2019-0066
- https://kb.netgear.com/000061232/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Switches-PSV-2019-0066
Get alerted when CVE-2019-20697 or the next vulnerability affects your stack