What’s Vulnerable › Vulnerabilities
CVE-2019-20705
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D3600 before 1.0.0.76, D6000 before 1.0.0.76, and XR500 before 2.3.2.32.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR D6000 Firmware: before 1.0.0.76 — fixed in 1.0.0.76
- NETGEAR Xr500 Firmware: before 2.3.2.32 — fixed in 2.3.2.32
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.76; NETGEAR D6000 Firmware 1.0.0.76; NETGEAR Xr500 Firmware 2.3.2.32. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061224/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-and-Gateways-PSV-2018-0391
- https://kb.netgear.com/000061224/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-and-Gateways-PSV-2018-0391
Get alerted when CVE-2019-20705 or the next vulnerability affects your stack