What’s Vulnerable › Vulnerabilities

CVE-2019-20712

Description

Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects D6220 before 1.0.0.52, D6400 before 1.0.0.86, D7000v2 before 1.0.0.53, D8500 before 1.0.3.44, DGN2200v4 before 1.0.0.110, DGND2200Bv4 before 1.0.0.109, R6250 before 1.0.4.34, R6300v2 before 1.0.4.32, R6400 before 1.0.1.46, R6400v2 before 1.0.2.62, R6700 before 1.0.2.6, R6900 before 1.0.2.4, R6900P before 1.3.1.64, R7000 before 1.0.9.60, R7000P before 1.3.1.64, R7100LG before 1.0.0.52, R7300DST before 1.0.0.70, R7900 before 1.0.3.8, R7900P before 1.4.1.30, R8000 before 1.0.4.28, R8000P before 1.4.1.30, R8300 before 1.0.2.128, R8500 before 1.0.2.128, WNDR3400v3 before 1.0.1.24, and WNR3500Lv2 before 1.2.0.56.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.52; Netgear D6400 1.0.0.86; NETGEAR D7000 Firmware 1.0.0.53; NETGEAR D8500 Firmware 1.0.3.44; NETGEAR Dgn2200 Firmware 1.0.0.110; NETGEAR Dgnd2200B Firmware 1.0.0.109; NETGEAR R6250 Firmware 1.0.4.34; NETGEAR R6300 Firmware 1.0.4.32; NETGEAR R6400 Firmware 1.0.1.46, 1.0.2.62; NETGEAR R6700 1.0.2.6; NETGEAR R6900 Firmware 1.0.2.4; NETGEAR R6900P Firmware 1.3.1.64. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20712 or the next vulnerability affects your stack