What’s Vulnerable › Vulnerabilities

CVE-2019-20713

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D8500 before 1.0.3.44, R6250 before 1.0.4.34, R6300v2 before 1.0.4.32, R6400 before 1.0.1.46, R6700 before 1.0.2.6, R6900 before 1.0.2.4, R6900P before 1.3.1.64, R7000 before 1.0.9.42, R7000P before 1.3.1.64, R7100LG before 1.0.0.50, R7300DST before 1.0.0.70, R7900 before 1.0.3.8, R7900P before 1.4.1.30, R8000 before 1.0.4.28, R8000P before 1.4.1.30, R8300 before 1.0.2.128, and R8500 before 1.0.2.128.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D8500 Firmware 1.0.3.44; NETGEAR R6250 Firmware 1.0.4.34; NETGEAR R6300 Firmware 1.0.4.32; NETGEAR R6400 Firmware 1.0.1.46; NETGEAR R6700 1.0.2.6; NETGEAR R6900 Firmware 1.0.2.4; NETGEAR R6900P Firmware 1.3.1.64; NETGEAR R7000 1.0.9.42; NETGEAR R7000P 1.3.1.64; NETGEAR R7100Lg Firmware 1.0.0.50; NETGEAR R7300Dst Firmware 1.0.0.70; NETGEAR R7900 Firmware 1.0.3.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20713 or the next vulnerability affects your stack