What’s Vulnerable › Vulnerabilities
CVE-2019-20716
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects DGN2200v4 before 1.0.0.110 and DGND2200Bv4 before 1.0.0.109.
Affected products
- NETGEAR Dgn2200 Firmware: before 1.0.0.110 — fixed in 1.0.0.110
- NETGEAR Dgnd2200B Firmware: before 1.0.0.109 — fixed in 1.0.0.109
How to fix
Upgrade to a fixed version: NETGEAR Dgn2200 Firmware 1.0.0.110; NETGEAR Dgnd2200B Firmware 1.0.0.109. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061212/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-DGN2200v4-and-DGND2200Bv4-PSV-2018-0241
- https://kb.netgear.com/000061212/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-DGN2200v4-and-DGND2200Bv4-PSV-2018-0241
Get alerted when CVE-2019-20716 or the next vulnerability affects your stack