What’s Vulnerable › Vulnerabilities

CVE-2019-20719

Description

Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects D6220 before 1.0.0.48, D6400 before 1.0.0.82, D7000v2 before 1.0.0.52, D8500 before 1.0.3.43, R6250 before 1.0.4.34, R6400 before 1.0.1.44, R6400v2 before 1.0.2.62, R7000P before 1.4.1.30, R7100LG before 1.0.0.48, R7300DST before 1.0.0.68, R7900 before 1.0.3.8, R7900P before 1.4.1.30, R8000 before 1.0.4.28, R8000P before 1.4.1.30, R8300 before 1.0.2.128, and R8500 before 1.0.2.128.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.48; Netgear D6400 1.0.0.82; NETGEAR D7000 Firmware 1.0.0.52; NETGEAR D8500 Firmware 1.0.3.43; NETGEAR R6250 Firmware 1.0.4.34; NETGEAR R6400 Firmware 1.0.1.44, 1.0.2.62; NETGEAR R7000P 1.4.1.30; NETGEAR R7100Lg Firmware 1.0.0.48; NETGEAR R7300Dst Firmware 1.0.0.68; NETGEAR R7900 Firmware 1.0.3.8; NETGEAR R7900P Firmware 1.4.1.30; NETGEAR R8000 Firmware 1.0.4.28. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20719 or the next vulnerability affects your stack