What’s Vulnerable › Vulnerabilities

CVE-2019-20722

Description

Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D7800 before 1.0.1.44, DM200 before 1.0.0.58, R7500v2 before 1.0.3.38, R7800 before 1.0.2.52, R8900 before 1.0.4.2, R9000 before 1.0.4.2, RBK20 before 2.3.0.28, RBR20 before 2.3.0.28, RBS20 before 2.3.0.28, RBK50 before 2.3.0.32, RBR50 before 2.3.0.32, RBS50 before 2.3.0.32, RBS40 before 2.3.0.28, WNDR4300v2 before 1.0.0.58, WNDR4500v3 before 1.0.0.58, WNR2000v5 before 1.0.0.68, and XR500 before 2.3.2.32.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.44; NETGEAR Dm200 Firmware 1.0.0.58; NETGEAR R7500 Firmware 1.0.3.38; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.2; NETGEAR R9000 Firmware 1.0.4.2; NETGEAR Rbk20 Firmware 2.3.0.28; NETGEAR Rbk50 Firmware 2.3.0.32; NETGEAR Rbr20 Firmware 2.3.0.28; NETGEAR Rbr50 Firmware 2.3.0.32; NETGEAR Rbs20 Firmware 2.3.0.28; NETGEAR Rbs40 Firmware 2.3.0.28. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20722 or the next vulnerability affects your stack