What’s Vulnerable › Vulnerabilities
CVE-2019-20728
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects D6400 before 1.0.0.74, D7000v2 before 1.0.0.74, D7800 before 1.0.1.34, D8500 before 1.0.3.39, DGN2200v4 before 1.0.0.102, DGND2200Bv4 before 1.0.0.102, DM200 before 1.0.0.52, JNDR3000 before 1.0.0.22, RBK50 before 2.3.5.30, RBR50 before 2.3.5.30, RBS50 before 2.3.5.30, RBW30 before 2.1.2.6, R6250 before 1.0.4.26, R6300v2 before 1.0.4.24, R6400 before 1.0.1.36, R6400v2 before 1.0.2.52, R6700 before 1.0.1.44, R6900 before 1.0.1.44, R7000 before 1.0.9.26, R6900P before 1.3.0.20, R7000P before 1.3.0.20, R7100LG before 1.0.0.40, R7300DST before 1.0.0.62, R7500v2 before 1.0.3.26, R7800 before 1.0.2.44, R7900 before 1.0.2.10, R8000 before 1.0.4.12, R7900P before 1.3.0.10, R8000P before 1.3.0.10, R8300 before 1.0.2.116, R8500 before 1.0.2.116, R8900 before 1.0.3.10, R9000 before 1.0.3.10, WNDR3400v3 before 1.0.1.18, WNDR3700v4 before 1.0.2.96, WNDR4300v1 before 1.0.2.98, WNDR4300v2 before 1.0.0.54, WNDR4500v3 before 1.0.0.54, WNR2000v5 before 1.0.0.64, and WNR3500Lv2 before 1.2.0.48.
Affected products
- Netgear D6400: before 1.0.0.74 — fixed in 1.0.0.74
- NETGEAR D7000 Firmware: before 1.0.0.74 — fixed in 1.0.0.74
- NETGEAR D7800 Firmware: before 1.0.1.34 — fixed in 1.0.1.34
- NETGEAR D8500 Firmware: before 1.0.3.39 — fixed in 1.0.3.39
- NETGEAR Dgn2200 Firmware: before 1.0.0.102 — fixed in 1.0.0.102
- NETGEAR Dgnd2200B Firmware: before 1.0.0.102 — fixed in 1.0.0.102
- NETGEAR Dm200 Firmware: before 1.0.0.52 — fixed in 1.0.0.52
- NETGEAR Jndr3000 Firmware: before 1.0.0.22 — fixed in 1.0.0.22
- NETGEAR R6250 Firmware: before 1.0.4.26 — fixed in 1.0.4.26
- NETGEAR R6300 Firmware: before 1.0.4.24 — fixed in 1.0.4.24
- NETGEAR R6400 Firmware: before 1.0.1.36; before 1.0.2.52 — fixed in 1.0.1.36, 1.0.2.52
- NETGEAR R6700: before 1.0.1.44 — fixed in 1.0.1.44
- NETGEAR R6900 Firmware: before 1.0.1.44 — fixed in 1.0.1.44
- NETGEAR R6900P Firmware: before 1.3.0.20 — fixed in 1.3.0.20
- NETGEAR R7000: before 1.0.9.26 — fixed in 1.0.9.26
- NETGEAR R7000P: before 1.3.0.20 — fixed in 1.3.0.20
- NETGEAR R7100Lg Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR R7300Dst Firmware: before 1.0.0.62 — fixed in 1.0.0.62
- NETGEAR R7500 Firmware: before 1.0.3.26 — fixed in 1.0.3.26
- NETGEAR R7800 Firmware: before 1.0.2.44 — fixed in 1.0.2.44
- NETGEAR R7900 Firmware: before 1.0.2.10 — fixed in 1.0.2.10
- NETGEAR R7900P Firmware: before 1.3.0.10 — fixed in 1.3.0.10
- NETGEAR R8000 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R8000P Firmware: before 1.3.0.10 — fixed in 1.3.0.10
- NETGEAR R8300 Firmware: before 1.0.2.116 — fixed in 1.0.2.116
- NETGEAR R8500 Firmware: before 1.0.2.116 — fixed in 1.0.2.116
- NETGEAR R8900 Firmware: before 1.0.3.10 — fixed in 1.0.3.10
- NETGEAR R9000 Firmware: before 1.0.3.10 — fixed in 1.0.3.10
- NETGEAR Rbk50 Firmware: before 2.3.5.30 — fixed in 2.3.5.30
- NETGEAR Rbr50 Firmware: before 2.3.5.30 — fixed in 2.3.5.30
How to fix
Upgrade to a fixed version: Netgear D6400 1.0.0.74; NETGEAR D7000 Firmware 1.0.0.74; NETGEAR D7800 Firmware 1.0.1.34; NETGEAR D8500 Firmware 1.0.3.39; NETGEAR Dgn2200 Firmware 1.0.0.102; NETGEAR Dgnd2200B Firmware 1.0.0.102; NETGEAR Dm200 Firmware 1.0.0.52; NETGEAR Jndr3000 Firmware 1.0.0.22; NETGEAR R6250 Firmware 1.0.4.26; NETGEAR R6300 Firmware 1.0.4.24; NETGEAR R6400 Firmware 1.0.1.36, 1.0.2.52; NETGEAR R6700 1.0.1.44. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061199/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-Gateways-and-WiFi-Systems-PSV-2017-315
- https://kb.netgear.com/000061199/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-Gateways-and-WiFi-Systems-PSV-2017-315
Get alerted when CVE-2019-20728 or the next vulnerability affects your stack