What’s Vulnerable › Vulnerabilities
CVE-2019-20730
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-89
Description
Certain NETGEAR devices are affected by SQL injection. This affects D3600 before 1.0.0.68, D6000 before 1.0.0.68, D6200 before 1.1.00.28, D6220 before 1.0.0.40, D6400 before 1.0.0.74, D7000 before 1.0.1.60, D7000v2 before 1.0.0.74, D7800 before 1.0.1.34, D8500 before 1.0.3.39, DC112A before 1.0.0.40, EX8000 before 1.0.0.118, JR6150 before 1.0.1.18, R6050 before 1.0.1.18, R6220 before 1.1.0.66, R6250 before 1.0.4.26, R6300v2 before 1.0.4.24, R6400 before 1.0.1.36, R6400v2 before 1.0.2.52, R6700 before 1.0.1.44, R6700v2 before 1.2.0.16, R6800 before 1.2.0.16, R6900v2 before 1.2.0.16, R6900 before 1.0.1.44, R7000 before 1.0.9.26, R6900P before 1.3.0.20, R7000P before 1.3.0.20, R7100LG before 1.0.0.40, R7300DST before 1.0.0.62, R7500 before 1.0.0.118, R7500v2 before 1.0.3.26, R7800 before 1.0.2.40, R7900 before 1.0.2.10, R8000 before 1.0.4.12, R7900P before 1.3.0.10, R8000P before 1.3.0.10, R8300 before 1.0.2.116, R8500 before 1.0.2.116, R8900 before 1.0.3.6, R9000 before 1.0.3.10, WNDR3700v4 before 1.0.2.102, WNDR3700v5 before 1.1.0.54, WNDR4300v1 before 1.0.2.98, WNDR4300v2 before 1.0.0.56, and WNDR4500v3 before 1.0.0.56.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.68 — fixed in 1.0.0.68
- NETGEAR D6000 Firmware: before 1.0.0.68 — fixed in 1.0.0.68
- NETGEAR D6200 Firmware: before 1.1.00.28 — fixed in 1.1.00.28
- NETGEAR D6220 Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- Netgear D6400: before 1.0.0.74 — fixed in 1.0.0.74
- NETGEAR D7000 Firmware: before 1.0.1.60; before 1.0.0.74 — fixed in 1.0.0.74, 1.0.1.60
- NETGEAR D7800 Firmware: before 1.0.1.34 — fixed in 1.0.1.34
- NETGEAR D8500 Firmware: before 1.0.3.39 — fixed in 1.0.3.39
- NETGEAR Dc112A Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR Ex8000 Firmware: before 1.0.0.118 — fixed in 1.0.0.118
- NETGEAR JR6150: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR R6050 Firmware: before 1.0.1.18 — fixed in 1.0.1.18
- NETGEAR R6220 Firmware: before 1.1.0.66 — fixed in 1.1.0.66
- NETGEAR R6250 Firmware: before 1.0.4.26 — fixed in 1.0.4.26
- NETGEAR R6300 Firmware: before 1.0.4.24 — fixed in 1.0.4.24
- NETGEAR R6400 Firmware: before 1.0.1.36; before 1.0.2.52 — fixed in 1.0.1.36, 1.0.2.52
- NETGEAR R6700: before 1.0.1.44; before 1.2.0.16 — fixed in 1.0.1.44, 1.2.0.16
- NETGEAR R6800 Firmware: before 1.2.0.16 — fixed in 1.2.0.16
- NETGEAR R6900 Firmware: before 1.2.0.16; before 1.0.1.44 — fixed in 1.0.1.44, 1.2.0.16
- NETGEAR R6900P Firmware: before 1.3.0.20 — fixed in 1.3.0.20
- NETGEAR R7000: before 1.0.9.26 — fixed in 1.0.9.26
- NETGEAR R7000P: before 1.3.0.20 — fixed in 1.3.0.20
- NETGEAR R7100Lg Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR R7300Dst Firmware: before 1.0.0.62 — fixed in 1.0.0.62
- NETGEAR R7500 Firmware: before 1.0.0.118; before 1.0.3.26 — fixed in 1.0.0.118, 1.0.3.26
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR R7900 Firmware: before 1.0.2.10 — fixed in 1.0.2.10
- NETGEAR R7900P Firmware: before 1.3.0.10 — fixed in 1.3.0.10
- NETGEAR R8000 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R8000P Firmware: before 1.3.0.10 — fixed in 1.3.0.10
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.68; NETGEAR D6000 Firmware 1.0.0.68; NETGEAR D6200 Firmware 1.1.00.28; NETGEAR D6220 Firmware 1.0.0.40; Netgear D6400 1.0.0.74; NETGEAR D7000 Firmware 1.0.0.74, 1.0.1.60; NETGEAR D7800 Firmware 1.0.1.34; NETGEAR D8500 Firmware 1.0.3.39; NETGEAR Dc112A Firmware 1.0.0.40; NETGEAR Ex8000 Firmware 1.0.0.118; NETGEAR JR6150 1.0.1.18; NETGEAR R6050 Firmware 1.0.1.18. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061197/Security-Advisory-for-SQL-Injection-on-Some-Routers-Gateways-and-Extenders-PSV-2017-3056
- https://kb.netgear.com/000061197/Security-Advisory-for-SQL-Injection-on-Some-Routers-Gateways-and-Extenders-PSV-2017-3056
Get alerted when CVE-2019-20730 or the next vulnerability affects your stack