What’s Vulnerable › Vulnerabilities
CVE-2019-20734
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects D6220 before 1.0.0.40, D8500 before 1.0.3.39, EX3700 before 1.0.0.70, EX3800 before 1.0.0.70, EX6000 before 1.0.0.30, EX6100 before 1.0.2.22, EX6120 before 1.0.0.40, EX6130 before 1.0.0.22, EX6150v1 before 1.0.0.42, EX6200 before 1.0.3.88, EX7000 before 1.0.0.66, R6300v2 before 1.0.4.18, R6400 before 1.0.1.24, R6400v2 before 1.0.2.32, R6700 before 1.0.1.22, R6700v3 before 1.0.2.32, R6900 before 1.0.1.22, R7000 before 1.0.9.6, R6900P before 1.0.0.56, R7000P before 1.0.0.56, R7100LG before 1.0.0.42, R7300DST before 1.0.0.54, R7900 before 1.0.1.26, R8300 before 1.0.2.106, R8500 before 1.0.2.106, WN2500RPv2 before 1.0.1.54, and WNR3500Lv2 before 1.2.0.46. NOTE: this may be a result of an incomplete fix for CVE-2017-18864.
Affected products
- NETGEAR D6220 Firmware: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR D8500 Firmware: before 1.0.3.39 — fixed in 1.0.3.39
- NETGEAR EX3700: before 1.0.0.70 — fixed in 1.0.0.70
- NETGEAR Ex3800 Firmware: before 1.0.0.70 — fixed in 1.0.0.70
- NETGEAR Ex6000 Firmware: before 1.0.0.30 — fixed in 1.0.0.30
- Netgear EX6100: before 1.0.2.22 — fixed in 1.0.2.22
- NETGEAR EX6120: before 1.0.0.40 — fixed in 1.0.0.40
- NETGEAR Ex6130 Firmware: before 1.0.0.22 — fixed in 1.0.0.22
- Netgear EX6150: before 1.0.0.42 — fixed in 1.0.0.42
- Netgear EX6200: before 1.0.3.88 — fixed in 1.0.3.88
- NETGEAR Ex7000 Firmware: before 1.0.0.66 — fixed in 1.0.0.66
- NETGEAR R6300 Firmware: before 1.0.4.18 — fixed in 1.0.4.18
- NETGEAR R6400 Firmware: before 1.0.1.24; before 1.0.2.32 — fixed in 1.0.1.24, 1.0.2.32
- NETGEAR R6700: before 1.0.1.22; before 1.0.2.32 — fixed in 1.0.1.22, 1.0.2.32
- NETGEAR R6900 Firmware: before 1.0.1.22 — fixed in 1.0.1.22
- NETGEAR R6900P Firmware: before 1.0.0.56 — fixed in 1.0.0.56
- NETGEAR R7000: before 1.0.9.6 — fixed in 1.0.9.6
- NETGEAR R7000P: before 1.0.0.56 — fixed in 1.0.0.56
- NETGEAR R7100Lg Firmware: before 1.0.0.42 — fixed in 1.0.0.42
- NETGEAR R7300Dst Firmware: before 1.0.0.54 — fixed in 1.0.0.54
- NETGEAR R7900 Firmware: before 1.0.1.26 — fixed in 1.0.1.26
- NETGEAR R8300 Firmware: before 1.0.2.106 — fixed in 1.0.2.106
- NETGEAR R8500 Firmware: before 1.0.2.106 — fixed in 1.0.2.106
- NETGEAR Wn2500Rp Firmware: before 1.0.1.54 — fixed in 1.0.1.54
- NETGEAR Wnr3500L Firmware: before 1.2.0.46 — fixed in 1.2.0.46
How to fix
Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.40; NETGEAR D8500 Firmware 1.0.3.39; NETGEAR EX3700 1.0.0.70; NETGEAR Ex3800 Firmware 1.0.0.70; NETGEAR Ex6000 Firmware 1.0.0.30; Netgear EX6100 1.0.2.22; NETGEAR EX6120 1.0.0.40; NETGEAR Ex6130 Firmware 1.0.0.22; Netgear EX6150 1.0.0.42; Netgear EX6200 1.0.3.88; NETGEAR Ex7000 Firmware 1.0.0.66; NETGEAR R6300 Firmware 1.0.4.18. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061192/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-Gateways-and-Extenders-PSV-2017-0791
- https://kb.netgear.com/000061192/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-Gateways-and-Extenders-PSV-2017-0791
Get alerted when CVE-2019-20734 or the next vulnerability affects your stack