What’s Vulnerable › Vulnerabilities

CVE-2019-20735

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D3600 before 1.0.0.75, D6000 before V1.0.0.75, D6100 before V1.0.0.63, R7800 before v1.0.2.52, R8900 before v1.0.4.2, R9000 before v1.0.4.2, RBK50 before v2.3.0.32, RBR50 before v2.3.0.32, RBS50 before v2.3.0.32, WNDR3700v4 before V1.0.2.102, WNDR4300v1 before V1.0.2.104, WNDR4300v2 before v1.0.0.58, WNDR4500v3 before v1.0.0.58, WNR2000v5 before v1.0.0.68, and XR500 before V2.3.2.32.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.75; NETGEAR D6000 Firmware 1.0.0.75; NETGEAR D6100 Firmware 1.0.0.63; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.2; NETGEAR R9000 Firmware 1.0.4.2; NETGEAR Rbk50 Firmware 2.3.0.32; NETGEAR Rbr50 Firmware 2.3.0.32; NETGEAR Rbs50 Firmware 2.3.0.32; NETGEAR Wndr3700 Firmware 1.0.2.102; NETGEAR Wndr4300 Firmware 1.0.0.58, 1.0.2.104; Netgear WNDR4500 1.0.0.58. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20735 or the next vulnerability affects your stack