What’s Vulnerable › Vulnerabilities

CVE-2019-20738

Description

Certain NETGEAR devices are affected by stored XSS. This affects D6100 before 1.0.0.58, D7800 before 1.0.1.34, JNR1010v2 before 1.1.0.50, JWNR2010v5 before 1.1.0.50, RBK50 before 2.3.5.30, RBR50 before 2.3.5.30, RBS50 before 2.3.5.30, R6020 before 1.0.0.30, R6080 before 1.0.0.30, R6100 before 1.0.1.16, R6120 before 1.0.0.40, R6700v2 before 1.2.0.14, R6800 before 1.2.0.14, R6900v2 before 1.2.0.14, R7500v2 before 1.0.3.26, R7800 before 1.0.2.46, R9000 before 1.0.4.2, WN3000RPv2 before 1.0.0.52, WN3000RPv3 before 1.0.2.78, WNDR3700v4 before 1.0.2.102, WNDR3700v5 before 1.1.0.54, WNDR4300v1 before 1.0.2.104, WNDR4300v2 before 1.0.0.48, WNDR4500v3 before 1.0.0.48, WNR1000v4 before 1.1.0.50, WNR2000v5 before 1.0.0.64, WNR2020 before 1.1.0.50, and WNR2050 before 1.1.0.50. NOTE: this may be a result of an incomplete fix for CVE-2017-18866.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.58; NETGEAR D7800 Firmware 1.0.1.34; NETGEAR Jnr1010 Firmware 1.1.0.50; NETGEAR Jwnr2010 Firmware 1.1.0.50; NETGEAR R6020 Firmware 1.0.0.30; NETGEAR R6080 Firmware 1.0.0.30; NETGEAR R6100 Firmware 1.0.1.16; NETGEAR R6120 Firmware 1.0.0.40; NETGEAR R6700 1.2.0.14; NETGEAR R6800 Firmware 1.2.0.14; NETGEAR R6900 Firmware 1.2.0.14; NETGEAR R7500 Firmware 1.0.3.26. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20738 or the next vulnerability affects your stack