What’s Vulnerable › Vulnerabilities
CVE-2019-20739
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-120
Description
NETGEAR R8500 devices before v1.0.2.128 are affected by a buffer overflow by an unauthenticated attacker.
Affected products
- NETGEAR R8500 Firmware: before 1.0.2.128 — fixed in 1.0.2.128
How to fix
Upgrade to a fixed version: NETGEAR R8500 Firmware 1.0.2.128. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000061179/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-R8500-PSV-2017-0636
- https://kb.netgear.com/000061179/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-R8500-PSV-2017-0636
Get alerted when CVE-2019-20739 or the next vulnerability affects your stack