What’s Vulnerable › Vulnerabilities

CVE-2019-20740

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects DGN2200v4 before 1.0.0.110, DGND2200Bv4 before 1.0.0.109, R7300 before 1.0.0.70, R8300 before 1.0.2.130, and R8500 before 1.0.2.130.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR Dgn2200 Firmware 1.0.0.110; NETGEAR Dgnd2200B Firmware 1.0.0.109; NETGEAR R7300 Firmware 1.0.0.70; NETGEAR R8300 Firmware 1.0.2.130; NETGEAR R8500 Firmware 1.0.2.130. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20740 or the next vulnerability affects your stack