What’s Vulnerable › Vulnerabilities
CVE-2019-20745
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects WAC505 before 5.0.10.2 and WAC510 before 5.0.10.2.
Affected products
- NETGEAR Wac505 Firmware: before 5.0.10.2 — fixed in 5.0.10.2
- NETGEAR Wac510 Firmware: before 5.0.10.2 — fixed in 5.0.10.2
How to fix
Upgrade to a fixed version: NETGEAR Wac505 Firmware 5.0.10.2; NETGEAR Wac510 Firmware 5.0.10.2. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000060978/Security-Advisory-for-Post-Authentication-Command-Injection-on-WAC505-and-WAC510-PSV-2018-0610
- https://kb.netgear.com/000060978/Security-Advisory-for-Post-Authentication-Command-Injection-on-WAC505-and-WAC510-PSV-2018-0610
Get alerted when CVE-2019-20745 or the next vulnerability affects your stack