What’s Vulnerable › Vulnerabilities

CVE-2019-20747

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D6100 before 1.0.0.58, D7800 before 1.0.1.40, R7500v2 before 1.0.3.34, R7800 before 1.0.2.52, R8900 before 1.0.4.2, R9000 before 1.0.3.16, RAX120 before 1.0.0.74, RBK20 before 2.3.0.22, RBR20 before 2.3.0.22, RBS20 before 2.3.0.22, RBK50 before 2.3.0.22, RBR50 before 2.3.0.22, RBS50 before 2.3.0.22, RBK40 before 2.3.0.22, RBS40 before 2.3.0.22, SRK60 before 2.2.0.64, SRR60 before 2.2.0.64, SRS60 before 2.2.0.64, WNDR3700v4 before 1.0.2.102, WNDR4300 before 1.0.2.104, WNDR4300v2 before 1.0.0.56, WNDR4500v3 before 1.0.0.56, and WNR2000v5 before 1.0.0.66.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.58; NETGEAR D7800 Firmware 1.0.1.40; NETGEAR R7500 Firmware 1.0.3.34; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.2; NETGEAR R9000 Firmware 1.0.3.16; NETGEAR Rax120 Firmware 1.0.0.74; NETGEAR Rbk20 Firmware 2.3.0.22; NETGEAR Rbk40 Firmware 2.3.0.22; NETGEAR Rbk50 Firmware 2.3.0.22; NETGEAR Rbr20 Firmware 2.3.0.22; NETGEAR Rbr50 Firmware 2.3.0.22. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20747 or the next vulnerability affects your stack