What’s Vulnerable › Vulnerabilities
CVE-2019-20748
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D7800 before 1.0.1.44, R7500v2 before 1.0.3.38, R7800 before 1.0.2.52, RBK20 before 2.3.0.28, RBR20 before 2.3.0.28, RBS20 before 2.3.0.28, RBK40 before 2.3.0.28, RBS40 before 2.3.0.28, RBK50 before 2.3.0.32, RBR50 before 2.3.0.32, and RBS50 before 2.3.0.32.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.44 — fixed in 1.0.1.44
- NETGEAR R7500 Firmware: before 1.0.3.38 — fixed in 1.0.3.38
- NETGEAR R7800 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Rbk20 Firmware: before 2.3.0.28 — fixed in 2.3.0.28
- NETGEAR Rbk40 Firmware: before 2.3.0.28 — fixed in 2.3.0.28
- NETGEAR Rbk50 Firmware: before 2.3.0.32 — fixed in 2.3.0.32
- NETGEAR Rbr20 Firmware: before 2.3.0.28 — fixed in 2.3.0.28
- NETGEAR Rbr50 Firmware: before 2.3.0.32 — fixed in 2.3.0.32
- NETGEAR Rbs20 Firmware: before 2.3.0.28 — fixed in 2.3.0.28
- NETGEAR Rbs40 Firmware: before 2.3.0.28 — fixed in 2.3.0.28
- NETGEAR Rbs50 Firmware: before 2.3.0.32 — fixed in 2.3.0.32
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.44; NETGEAR R7500 Firmware 1.0.3.38; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR Rbk20 Firmware 2.3.0.28; NETGEAR Rbk40 Firmware 2.3.0.28; NETGEAR Rbk50 Firmware 2.3.0.32; NETGEAR Rbr20 Firmware 2.3.0.28; NETGEAR Rbr50 Firmware 2.3.0.32; NETGEAR Rbs20 Firmware 2.3.0.28; NETGEAR Rbs40 Firmware 2.3.0.28; NETGEAR Rbs50 Firmware 2.3.0.32. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000060963/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-Gateways-and-WiFi-Systems-PSV-2018-0147
- https://kb.netgear.com/000060963/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-Gateways-and-WiFi-Systems-PSV-2018-0147
Get alerted when CVE-2019-20748 or the next vulnerability affects your stack