What’s Vulnerable › Vulnerabilities

CVE-2019-20751

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D6100 before 1.0.0.60, DM200 before 1.0.0.61, EX2700 before 1.0.1.48, EX6100v2 before 1.0.1.76, EX6150v2 before 1.0.1.76, EX6200v2 before 1.0.1.72, EX8000 before 1.0.1.180, R7800 before 1.0.2.52, R8900 before 1.0.4.26, R9000 before 1.0.4.26, WN2000RPTv3 before 1.0.1.32, WN3000RPv2 before 1.0.0.68, WN3000RPv3 before 1.0.2.70, WN3100RPv2 before 1.0.0.66, WNDR4300v2 before 1.0.0.58, WNDR4500v3 before 1.0.0.58, and WNR2000v5 before 1.0.0.68.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.60; NETGEAR Dm200 Firmware 1.0.0.61; NETGEAR Ex2700 Firmware 1.0.1.48; Netgear EX6100 1.0.1.76; Netgear EX6150 1.0.1.76; Netgear EX6200 1.0.1.72; NETGEAR Ex8000 Firmware 1.0.1.180; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.26; NETGEAR R9000 Firmware 1.0.4.26; NETGEAR Wn2000Rpt Firmware 1.0.1.32; NETGEAR Wn3000Rp Firmware 1.0.0.68, 1.0.2.70. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20751 or the next vulnerability affects your stack