What’s Vulnerable › Vulnerabilities

CVE-2019-20752

Description

Certain NETGEAR devices are affected by stored XSS. This affects D3600 before 1.0.0.75, D6000 before 1.0.0.75, D7800 before 1.0.1.44, DM200 before 1.0.0.58, R7800 before 1.0.2.58, R8900 before 1.0.4.12, R9000 before 1.0.4.12, RBK20 before 2.3.0.28, RBR20 before 2.3.0.28, RBS20 before 2.3.0.28, RBK40 before 2.3.0.28, RBS40 before 2.3.0.28, RBK50 before 2.3.0.32, RBR50 before 2.3.0.32, RBS50 before 2.3.0.32, WN3000RPv2 before 1.0.0.68, WN3000RPv3 before 1.0.2.70, WN3100RPv2 before 1.0.0.60, WNDR4300v2 before 1.0.0.58, WNDR4500v3 before 1.0.0.58, and WNR2000v5 before 1.0.0.68.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.75; NETGEAR D6000 Firmware 1.0.0.75; NETGEAR D7800 Firmware 1.0.1.44; NETGEAR Dm200 Firmware 1.0.0.58; NETGEAR R7800 Firmware 1.0.2.58; NETGEAR R8900 Firmware 1.0.4.12; NETGEAR R9000 Firmware 1.0.4.12; NETGEAR Rbk20 Firmware 2.3.0.28; NETGEAR Rbk40 Firmware 2.3.0.28; NETGEAR Rbk50 Firmware 2.3.0.32; NETGEAR Rbr20 Firmware 2.3.0.28; NETGEAR Rbr50 Firmware 2.3.0.32. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20752 or the next vulnerability affects your stack