What’s Vulnerable › Vulnerabilities
CVE-2019-20753
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects DGN2200v1 before 1.0.0.58, D8500 before 1.0.3.42, D7000v2 before 1.0.0.51, D6400 before 1.0.0.78, D6220 before 1.0.0.44, JNDR3000 before 1.0.0.24, R8000 before 1.0.4.18, R8500 before 1.0.2.122, R8300 before 1.0.2.122, R7900 before 1.0.2.16, R7000P before 1.3.2.34, R7300DST before 1.0.0.68, R7100LG before 1.0.0.46, R6900P before 1.3.2.34, R7000 before 1.0.9.28, R6900 before 1.0.1.46, R6700 before 1.0.1.46, R6400v2 before 1.0.2.56, R6400 before 1.0.1.42, R6300v2 before 1.0.4.28, R6250 before 1.0.4.26, WNDR3400v3 before 1.0.1.22, WNDR4500v2 before 1.0.0.72, and WNR3500Lv2 before 1.2.0.50.
Affected products
- NETGEAR D6220 Firmware: before 1.0.0.44 — fixed in 1.0.0.44
- Netgear D6400: before 1.0.0.78 — fixed in 1.0.0.78
- NETGEAR D7000 Firmware: before 1.0.0.51 — fixed in 1.0.0.51
- NETGEAR D8500 Firmware: before 1.0.3.42 — fixed in 1.0.3.42
- NETGEAR Dgn2200 Firmware: before 1.0.0.58 — fixed in 1.0.0.58
- NETGEAR Jndr3000 Firmware: before 1.0.0.24 — fixed in 1.0.0.24
- NETGEAR R6250 Firmware: before 1.0.4.26 — fixed in 1.0.4.26
- NETGEAR R6300 Firmware: before 1.0.4.28 — fixed in 1.0.4.28
- NETGEAR R6400 Firmware: before 1.0.2.56; before 1.0.1.42 — fixed in 1.0.1.42, 1.0.2.56
- NETGEAR R6700: before 1.0.1.46 — fixed in 1.0.1.46
- NETGEAR R6900 Firmware: before 1.0.1.46 — fixed in 1.0.1.46
- NETGEAR R6900P Firmware: before 1.3.2.34 — fixed in 1.3.2.34
- NETGEAR R7000: before 1.0.9.28 — fixed in 1.0.9.28
- NETGEAR R7000P: before 1.3.2.34 — fixed in 1.3.2.34
- NETGEAR R7100Lg Firmware: before 1.0.0.46 — fixed in 1.0.0.46
- NETGEAR R7300Dst Firmware: before 1.0.0.68 — fixed in 1.0.0.68
- NETGEAR R7900 Firmware: before 1.0.2.16 — fixed in 1.0.2.16
- NETGEAR R8000 Firmware: before 1.0.4.18 — fixed in 1.0.4.18
- NETGEAR R8300 Firmware: before 1.0.2.122 — fixed in 1.0.2.122
- NETGEAR R8500 Firmware: before 1.0.2.122 — fixed in 1.0.2.122
- NETGEAR Wndr3400 Firmware: before 1.0.1.22 — fixed in 1.0.1.22
- Netgear WNDR4500: before 1.0.0.72 — fixed in 1.0.0.72
- NETGEAR Wnr3500L Firmware: before 1.2.0.50 — fixed in 1.2.0.50
How to fix
Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.44; Netgear D6400 1.0.0.78; NETGEAR D7000 Firmware 1.0.0.51; NETGEAR D8500 Firmware 1.0.3.42; NETGEAR Dgn2200 Firmware 1.0.0.58; NETGEAR Jndr3000 Firmware 1.0.0.24; NETGEAR R6250 Firmware 1.0.4.26; NETGEAR R6300 Firmware 1.0.4.28; NETGEAR R6400 Firmware 1.0.1.42, 1.0.2.56; NETGEAR R6700 1.0.1.46; NETGEAR R6900 Firmware 1.0.1.46; NETGEAR R6900P Firmware 1.3.2.34. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000060629/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-and-Modem-Routers-PSV-2018-0085
- https://kb.netgear.com/000060629/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-and-Modem-Routers-PSV-2018-0085
Get alerted when CVE-2019-20753 or the next vulnerability affects your stack