What’s Vulnerable › Vulnerabilities

CVE-2019-20754

Description

Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects DGN2200 before 1.0.0.58, DGN2200B before 1.0.0.58, D8500 before 1.0.3.42, D7000v2 before 1.0.0.51, D6400 before 1.0.0.80, D6220 before 1.0.0.44, EX7000 before 1.0.0.66, EX6200 before 1.0.3.88, EX6150 before 1.0.0.42, EX7500 before 1.0.0.46, JNDR3000 before 1.0.0.24, R8000 before 1.0.4.18, R8500 before 1.0.2.122, R8300 before 1.0.2.122, R7900P before 1.4.0.10, R8000P before 1.4.0.10, R7900 before 1.0.2.16, R7000P before 1.3.1.44, R7300DST before 1.0.0.68, R7100LG before 1.0.0.46, R6900P before 1.3.1.44, R7000 before 1.0.9.32, R6900 before 1.0.1.46, R6700 before 1.0.1.46, R6400v2 before 1.0.2.56, R6400 before 1.0.1.42, R6300v2 before 1.0.4.28, R6250 before 1.0.4.26, WNDR4500v2 before 1.0.0.72, and WNR3500Lv2 before 1.2.0.54.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.44; Netgear D6400 1.0.0.80; NETGEAR D7000 Firmware 1.0.0.51; NETGEAR D8500 Firmware 1.0.3.42; NETGEAR Dgn2200 Firmware 1.0.0.58; Netgear DGN2200B 1.0.0.58; Netgear EX6150 1.0.0.42; Netgear EX6200 1.0.3.88; NETGEAR Ex7000 Firmware 1.0.0.66; NETGEAR Ex7500 Firmware 1.0.0.46; NETGEAR Jndr3000 Firmware 1.0.0.24; NETGEAR R6250 Firmware 1.0.4.26. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20754 or the next vulnerability affects your stack