What’s Vulnerable › Vulnerabilities

CVE-2019-20756

Description

Certain NETGEAR devices are affected by reflected XSS. This affects EX7000 before 1.0.0.64, EX6200 before 1.0.3.86, EX6150 before 1.0.0.38, EX6130 before 1.0.0.22, EX6120 before 1.0.0.40, EX6100 before 1.0.2.22, EX6000 before 1.0.0.30, EX3700 before 1.0.0.70, EX3800 before 1.0.0.70, R8300 before 1.0.2.94, R7300DST before 1.0.0.62, R7000P before 1.3.0.20, R6900P before 1.3.0.20, R6400 before 1.0.1.32, R6300v2 before 1.0.4.24, R8500 before 1.0.2.94, WNDR3400v3 before 1.0.1.18, and WN2500RPv2 before 1.0.1.52.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR EX3700 1.0.0.70; NETGEAR Ex3800 Firmware 1.0.0.70; NETGEAR Ex6000 Firmware 1.0.0.30; Netgear EX6100 1.0.2.22; NETGEAR EX6120 1.0.0.40; NETGEAR Ex6130 Firmware 1.0.0.22; Netgear EX6150 1.0.0.38; Netgear EX6200 1.0.3.86; NETGEAR Ex7000 Firmware 1.0.0.64; NETGEAR R6300 Firmware 1.0.4.24; NETGEAR R6400 Firmware 1.0.1.32; NETGEAR R6900P Firmware 1.3.0.20. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20756 or the next vulnerability affects your stack