What’s Vulnerable › Vulnerabilities
CVE-2019-20758
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-16 · updated 2026-06-17
- Weakness: CWE-120
Description
NETGEAR R7000 devices before 1.0.9.42 are affected by a buffer overflow by an authenticated user.
Affected products
- NETGEAR R7000: before 1.0.9.42 — fixed in 1.0.9.42
How to fix
Upgrade to a fixed version: NETGEAR R7000 1.0.9.42. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000060641/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-R7000-PSV-2018-0377
- https://kb.netgear.com/000060641/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-R7000-PSV-2018-0377
Get alerted when CVE-2019-20758 or the next vulnerability affects your stack