What’s Vulnerable › Vulnerabilities
CVE-2019-20795
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-09 · updated 2026-10-14
- Weakness: CWE-416
Description
iproute2 before 5.1.0 has a use-after-free in get_netnsid_from_name in ip/ipnetns.c. NOTE: security relevance may be limited to certain uses of setuid that, although not a default, are sometimes a configuration option offered to end users. Even when setuid is used, other factors (such as C library configuration) may block exploitability.
Affected products
- Canonical Ubuntu Linux: 18.04
- Iproute2 Project Iproute2: before 5.1.0 — fixed in 5.1.0
How to fix
Upgrade to a fixed version: Iproute2 Project Iproute2 5.1.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1171452
- https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=9bf2c538a0eb10d66e2365a655bf6c52f5ba3d10
- https://security.gentoo.org/glsa/202008-06
- https://usn.ubuntu.com/4357-1/
- https://bugzilla.suse.com/show_bug.cgi?id=1171452
- https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/commit/?id=9bf2c538a0eb10d66e2365a655bf6c52f5ba3d10
- https://security.gentoo.org/glsa/202008-06
- https://usn.ubuntu.com/4357-1/
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2019-20795 or the next vulnerability affects your stack