What’s Vulnerable › Vulnerabilities
CVE-2019-20805
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-01 · updated 2026-06-17
- Weakness: CWE-190
Description
p_lx_elf.cpp in UPX before 3.96 has an integer overflow during unpacking via crafted values in a PT_DYNAMIC segment.
Affected products
- upx: before 3.96 — fixed in 3.96
How to fix
Upgrade to a fixed version: upx 3.96. Check the vendor advisory for mitigations.
References
- https://github.com/upx/upx/commit/8be9da8280dfa69d5df4417d4d81bda1cab78010
- https://github.com/upx/upx/issues/317
- https://github.com/upx/upx/commit/8be9da8280dfa69d5df4417d4d81bda1cab78010
- https://github.com/upx/upx/issues/317
Get alerted when CVE-2019-20805 or the next vulnerability affects your stack