What’s Vulnerable › Vulnerabilities
CVE-2019-20806
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-27 · updated 2026-06-17
- Weakness: CWE-476
Description
An issue was discovered in the Linux kernel before 5.2. There is a NULL pointer dereference in tw5864_handle_frame() in drivers/media/pci/tw5864/tw5864-video.c, which may cause denial of service, aka CID-2e7682ebfc75.
Affected products
- Linux kernel: before 5.2 — fixed in 5.2
How to fix
Upgrade to a fixed version: Linux kernel 5.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00022.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2e7682ebfc750177a4944eeb56e97a3f05734528
- https://github.com/torvalds/linux/commit/2e7682ebfc750177a4944eeb56e97a3f05734528
- https://lists.debian.org/debian-lts-announce/2020/06/msg00012.html
- https://security.netapp.com/advisory/ntap-20200619-0001/
- https://www.debian.org/security/2020/dsa-4698
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00022.html
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.2
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2e7682ebfc750177a4944eeb56e97a3f05734528
- https://github.com/torvalds/linux/commit/2e7682ebfc750177a4944eeb56e97a3f05734528
- https://lists.debian.org/debian-lts-announce/2020/06/msg00012.html
Get alerted when CVE-2019-20806 or the next vulnerability affects your stack