What’s Vulnerable › Vulnerabilities

CVE-2019-20838

Description

libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454.

Affected products

How to fix

Upgrade to a fixed version: Apple macOS 11.0.1; Pcre 8.43; Splunk Universal Forwarder 8.2.12, 9.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-20838 or the next vulnerability affects your stack