What’s Vulnerable › Vulnerabilities
CVE-2019-20855
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
Description
An issue was discovered in Mattermost Server before 5.16.1, 5.15.2, 5.14.5, and 5.9.6. It allows attackers to obtain sensitive information (local files) during legacy attachment migration.
Affected products
- Mattermost: before 5.9.6; from 5.14.0 before 5.14.5; from 5.15.0 before 5.15.2; from 5.16.0 before 5.16.1 — fixed in 5.14.5, 5.15.2, 5.16.1, 5.9.6
How to fix
Upgrade to a fixed version: Mattermost 5.14.5, 5.15.2, 5.16.1, 5.9.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-20855 or the next vulnerability affects your stack