What’s Vulnerable › Vulnerabilities
CVE-2019-20865
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue was discovered in Mattermost Server before 5.12.0, 5.11.1, 5.10.2, 5.9.2, and 4.10.10. The login page allows CSRF.
Affected products
- Mattermost: before 4.10.10; from 5.9.0 before 5.9.2; from 5.10.0 before 5.10.2; from 5.11.0 before 5.11.1; 5.12.0-rc1, 5.12.0-rc2, 5.12.0-rc3, 5.12.0-rc4, 5.12.0-rc5, 5.12.0-rc6 — fixed in 4.10.10, 5.10.2, 5.11.1, 5.9.2
How to fix
Upgrade to a fixed version: Mattermost 4.10.10, 5.10.2, 5.11.1, 5.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-20865 or the next vulnerability affects your stack