What’s Vulnerable › Vulnerabilities
CVE-2019-20891
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-19 · updated 2026-06-17
- Weakness: CWE-352
Description
WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site request forgery (CSRF) issue with resultant stored cross-site scripting (XSS) via includes/admin/importers/class-wc-product-csv-importer-controller.php.
Affected products
- Automattic WooCommerce: before 3.6.5 — fixed in 3.6.5
How to fix
Upgrade to a fixed version: Automattic WooCommerce 3.6.5. Check the vendor advisory for mitigations.
References
- https://blog.ripstech.com/2019/woocommerce-csrf-to-stored-xss/
- https://raw.githubusercontent.com/woocommerce/woocommerce/master/CHANGELOG.txt
- https://blog.ripstech.com/2019/woocommerce-csrf-to-stored-xss/
- https://raw.githubusercontent.com/woocommerce/woocommerce/master/CHANGELOG.txt
Get alerted when CVE-2019-20891 or the next vulnerability affects your stack