What’s Vulnerable › Vulnerabilities
CVE-2019-20918
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-11 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in InspIRCd 3 before 3.1.0. The silence module contains a use after free vulnerability. This vulnerability can be used for remote crashing of an InspIRCd server by any user able to fully connect to a server.
Affected products
- Inspircd: from 3.0 before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Inspircd 3.1.0. Check the vendor advisory for mitigations.
References
- https://docs.inspircd.org/security/2019-01/
- https://github.com/inspircd/inspircd/commit/7b47de3c194f239c5fea09a0e49696c9af017d51
- https://github.com/inspircd/inspircd/commit/bcd65de1ec4bb71591ae417fee649d7ecd37cd57
- https://docs.inspircd.org/security/2019-01/
- https://github.com/inspircd/inspircd/commit/7b47de3c194f239c5fea09a0e49696c9af017d51
- https://github.com/inspircd/inspircd/commit/bcd65de1ec4bb71591ae417fee649d7ecd37cd57
Get alerted when CVE-2019-20918 or the next vulnerability affects your stack