What’s Vulnerable › Vulnerabilities
CVE-2019-20921
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-30 · updated 2026-06-17
- Weakness: CWE-79
Description
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
Affected products
- Snapappointments Bootstrap-Select: before 1.13.6 — fixed in 1.13.6
How to fix
Upgrade to a fixed version: Snapappointments Bootstrap-Select 1.13.6. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-9r7h-6639-v5mw
- https://github.com/snapappointments/bootstrap-select/issues/2199
- https://issues.jtl-software.de/issues/SHOP-7964
- https://snyk.io/vuln/SNYK-JS-BOOTSTRAPSELECT-570457
- https://www.npmjs.com/advisories/1522
- https://github.com/advisories/GHSA-9r7h-6639-v5mw
- https://github.com/snapappointments/bootstrap-select/issues/2199
- https://snyk.io/vuln/SNYK-JS-BOOTSTRAPSELECT-570457
- https://www.npmjs.com/advisories/1522
Get alerted when CVE-2019-20921 or the next vulnerability affects your stack