What’s Vulnerable › Vulnerabilities
CVE-2019-20924: Invariant in IndexBoundsBuilder
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-394
Description
A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries which trigger an invariant in the IndexBoundsBuilder. This issue affects MongoDB Server v4.2 versions prior to 4.2.2.
Affected products
- MongoDB: from 4.2.0 before 4.2.2 — fixed in 4.2.2
How to fix
Upgrade to a fixed version: MongoDB 4.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-20924 or the next vulnerability affects your stack