What’s Vulnerable › Vulnerabilities
CVE-2019-20925: Denial of service via malformed network packet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-24 · updated 2026-06-17
- Weakness: CWE-839
Description
An unauthenticated client can trigger denial of service by issuing specially crafted wire protocol messages, which cause the message decompressor to incorrectly allocate memory. This issue affects MongoDB Server v4.2 versions prior to 4.2.1; MongoDB Server v4.0 versions prior to 4.0.13; MongoDB Server v3.6 versions prior to 3.6.15 and MongoDB Server v3.4 versions prior to 3.4.24.
Affected products
- MongoDB: from 3.4.0 before 3.4.24; from 3.6.0 before 3.6.15; from 4.0.0 before 4.0.13; from 4.2.0 before 4.2.1 — fixed in 3.4.24, 3.6.15, 4.0.13, 4.2.1
How to fix
Upgrade to a fixed version: MongoDB 3.4.24, 3.6.15, 4.0.13, 4.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-20925 or the next vulnerability affects your stack