What’s Vulnerable › Vulnerabilities
CVE-2019-20933
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-19 · updated 2026-06-17
- Weakness: CWE-287
Description
InfluxDB before 1.7.6 has an authentication bypass vulnerability in the authenticate function in services/httpd/handler.go because a JWT token may have an empty SharedSecret (aka shared secret).
Affected products
- Debian Linux: 9.0, 10.0
- Influxdata Influxdb: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: Influxdata Influxdb 1.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/influxdata/influxdb/commit/761b557315ff9c1642cf3b0e5797cd3d983a24c0
- https://github.com/influxdata/influxdb/compare/v1.7.5...v1.7.6
- https://github.com/influxdata/influxdb/issues/12927
- https://lists.debian.org/debian-lts-announce/2020/12/msg00030.html
- https://www.debian.org/security/2021/dsa-4823
- https://github.com/influxdata/influxdb/commit/761b557315ff9c1642cf3b0e5797cd3d983a24c0
- https://github.com/influxdata/influxdb/compare/v1.7.5...v1.7.6
- https://github.com/influxdata/influxdb/issues/12927
- https://lists.debian.org/debian-lts-announce/2020/12/msg00030.html
- https://www.debian.org/security/2021/dsa-4823
Get alerted when CVE-2019-20933 or the next vulnerability affects your stack