What’s Vulnerable › Vulnerabilities
CVE-2019-2390: Code execution on Windows via OpenSSL engine injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-30 · updated 2026-06-17
- Weakness: CWE-94
Description
An unprivileged user or program on Microsoft Windows which can create OpenSSL configuration files in a fixed location may cause utility programs shipped with MongoDB server to run attacker defined code as the user running the utility. This issue MongoDB Server v4.0 versions prior to 4.0.11; MongoDB Server v3.6 versions prior to 3.6.14 and MongoDB Server v3.4 prior to 3.4.22.
Affected products
- MongoDB: from 3.4.0 before 3.4.22; from 3.6.0 before 3.6.14; from 4.0.0 before 4.0.11 — fixed in 3.4.22, 3.6.14, 4.0.11
How to fix
Upgrade to a fixed version: MongoDB 3.4.22, 3.6.14, 4.0.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-2390 or the next vulnerability affects your stack