What’s Vulnerable › Vulnerabilities

CVE-2019-2392: $mod can result in undefined behavior

Description

A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which use the $mod operator to overflow negative values. This issue affects: MongoDB Inc. MongoDB Server v4.4 versions prior to 4.4.1; v4.2 versions prior to 4.2.9; v4.0 versions prior to 4.0.20; v3.6 versions prior to 3.6.20.

Affected products

How to fix

Upgrade to a fixed version: MongoDB 3.6.20, 4.0.20, 4.2.9, 4.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-2392 or the next vulnerability affects your stack