What’s Vulnerable › Vulnerabilities

CVE-2019-2393: Crash while joining collections with $lookup

Description

A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which use $lookup and collations. This issue affects MongoDB Server v4.2 versions prior to 4.2.1; MongoDB Server v4.0 versions prior to 4.0.13 and MongoDB Server v3.6 versions prior to 3.6.15.

Affected products

How to fix

Upgrade to a fixed version: MongoDB 3.6.15, 4.0.13, 4.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-2393 or the next vulnerability affects your stack