What’s Vulnerable › Vulnerabilities
CVE-2019-25004
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-31 · updated 2026-06-17
Description
An issue was discovered in the flatbuffers crate before 0.6.1 for Rust. Arbitrary bytes can be reinterpreted as a bool, defeating soundness.
Affected products
- Google Flatbuffers: from 0.4.0 before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: Google Flatbuffers 0.6.1. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2019-0028.html
- https://rustsec.org/advisories/RUSTSEC-2019-0028.html
Get alerted when CVE-2019-25004 or the next vulnerability affects your stack